In preparation for iPhone OS 3.0 release, Apple releases an update (v8.2) of iTunes. According to Apple, iTunes v8.2 supports iPhone and iPod Touch with iPhone 3.0 update (not released yet). And, it also includes many accessibility improvement and bug fixes.

iTunes 8.2 version for Jailbreaker

I suggest you to hold off the upgrade if you’re using jailbroken iPhone or you plan for jailbreak. As mentioned by iPhone Dev-Team, iTunes 8.2 will break the use of QuickPwn and PwnageTool, as well as iPhone Tunneling Suite (ssh over usb). The incompatibility is due to the update of a low-level USB protocol that normally Apple and jailbreaker care about.

iPhone Dev team also mentioned that the incompatibility of iTunes 8.2 and QuickPwn/PwnageTool can be fixed. But you should not expect an update of QuickPwn/PwnageTool until the official release of iPhone 3.0.

So, jailbreaker. For now, you should hold off the upgrade of iTunes 8.2 and use lower version of iTunes to jailbreak.

0 comments

There was an error in this gadget